DigitalOcean Services Status

App Platform Deployments
Incident Report for DigitalOcean
Resolved
Our Engineering team has confirmed the full resolution of the issue impacting App Platform Deployments.

From 11:54 on Nov 2nd to 06:42 on Nov 4th UTC, App Platform users may have experienced delays when deploying new apps or when deploying updates to existing Apps. Our Upstream provider and the Engineering team closely worked together to resolve the issue.

The impact has been completely subsided and users should no longer see any issues with the impacted services.

If you continue to experience problems, please open a ticket with our support team from your Cloud Control Panel. Thank you for your patience and we apologize for any inconvenience.
Posted Nov 04, 2023 - 08:18 UTC
Update
As per the recent update from our Upstream provider, they fully recovered the services used by DigitalOcean and are moving towards a complete recovery of the rest of their services. App deployments have been successfully going through and the custom domains should be working fine now. We will post an update as soon as the issue is fully resolved.
Posted Nov 04, 2023 - 06:53 UTC
Update
Our upstream provider is still working on a fix but during this time our Engineering team noticed that our App Platform users might experience an issue with adding domains via App platform.  App deployments have been successfully going through and the custom domains that weren't working previously should be working fine now. We will keep you posted with any updates we receive from them.
Posted Nov 03, 2023 - 17:28 UTC
Update
According to the most recent update from our upstream provider, they are actively working on resolving the issue. We are observing a gradual improvement in the affected services.

We are closely monitoring the situation and will provide an update once the issue is completely resolved.
Posted Nov 03, 2023 - 07:26 UTC
Monitoring
The latest update from the Upstream provider is they are still working on a fix. Also, we have and continue to observe improving conditions and will continue to monitor the situation. We will post an update once we resolved the issue.
Posted Nov 03, 2023 - 01:23 UTC
Update
As per the recent update from our Upstream provider, they are continuing to work on a fix and are seeing some progress. From our end, we are monitoring the App deployments that are in the queued state to see if there is any positive trend in the success rate of the deployments.

We will keep you posted with any updates we receive from them.
Posted Nov 02, 2023 - 17:43 UTC
Identified
Our Engineering team has confirmed that an issue on our upstream provider's end is causing the App deployment delays on our platform.

We will share an update as soon as we have any information from our upstream provider.
Posted Nov 02, 2023 - 15:42 UTC
Investigating
As of 12:30 UTC, our Engineering team is investigating reports of an issue with our App Platform service. At this time, our App Platform users may experience delays when deploying new apps or when deploying updates to existing Apps.

We will provide an update as soon as we have additional information.
Posted Nov 02, 2023 - 12:40 UTC
This incident affected: App Platform (Global).