DigitalOcean Services Status

Internal Load Balancers Connectivity

Incident Report for DigitalOcean

Resolved

From 19:57 UTC to 01:03 UTC, customers may have experienced connectivity issues between Internal Load Balancers and their associated target droplets, which could have resulted in service disruption or traffic routing failures.

Our Engineering team has confirmed full resolution of the issue, and Internal Load Balancers should now be functioning normally.

If you continue to experience any problems, please open a ticket with our Support team. We apologize for any inconvenience caused.
Posted Mar 05, 2026 - 01:52 UTC

Monitoring

Our Engineering team has implemented mitigation measures to address the connectivity issues affecting Internal Load Balancers and their associated target droplets. We are actively monitoring the situation to ensure stability and to prevent any recurrence.

We will provide a further update once we confirm the issue is fully resolved.
Posted Mar 05, 2026 - 01:19 UTC

Investigating

Our Engineering team is investigating an issue affecting Internal Load Balancers. Customers may experience connectivity loss between Internal Load Balancers and their associated target droplets.

We apologize for the inconvenience and will share an update as soon as more information becomes available.
Posted Mar 05, 2026 - 00:23 UTC
This incident affected: Load Balancers (Global).