DigitalOcean Services Status

Managed Databases creation - PostgresSQL v16
Incident Report for DigitalOcean
Resolved
Our Engineering team has confirmed that creation, forking, and restoration of PostgreSQL clusters on v16 is functioning correctly.

Upgrades for lower-versioned PostgreSQL clusters to v16 remain unavailable at this time and users will see errors if they attempt to perform that upgrade. Our Engineering team continues to work on making upgrades to v16 available again, but we expect this to take some time.

If you continue to experience issues or have any questions, please open a ticket with our support team.
Posted Feb 28, 2024 - 22:53 UTC
Monitoring
After testing, teams have determined that PostgreSQL v16 is safe for new creations, as well as forks and restores for existing clusters. At this time, v16 is re-enabled in our Cloud Control Panel and users creating, forking, or restoring v16 clusters should be able to do so successfully.

We will now monitor new creates for a short period of time.
Posted Feb 28, 2024 - 20:56 UTC
Identified
The identified issue with the image used to create PostgreSQL v16 clusters has been reported upstream to Postgres. Engineering teams are currently engaged in testing the image to ensure it is safe for users to continue using for new cluster creations and upgrades.

Until that determination is made, customers are unable to create, fork, or restore v16 clusters, both through the Cloud Control Panel and API. Customers may use v15 or lower for new PostgreSQL cluster creations in the interim.

We appreciate your patience and will provide another update once we have more information.
Posted Feb 28, 2024 - 18:03 UTC
Update
Our Engineering team is continuing to investigate the root cause of this incident. During this period, users may encounter errors when trying to create PostgreSQL database clusters v16. We intend to re-enable the creation of PGSQL v16 database instances as soon as possible.

We will provide an update as soon as we have further information
Posted Feb 28, 2024 - 10:42 UTC
Update
During the course of investigation, our Engineering team has discovered there may be an issue with the image used to create PostgreSQL v16 Database Clusters. Due to this, our team is temporarily removing the option to create v16 clusters from our Cloud Control Panel, while they continue to work on addressing the root cause. Users attempting to create v16 clusters via the API will continue to receive errors. Additionally, users with existing v16 clusters will be unable to fork or restore those clusters until this incident is resolved.

We will continue to provide updates as they are available. In the meantime, users are free to create new clusters on versions other than v16.
Posted Feb 27, 2024 - 18:27 UTC
Update
Our Engineering team continues to investigate the root cause of this incident. During this time, users are unable to create v16 PostgreSQL Database Clusters.

We will provide an update as soon as we have further information.
Posted Feb 27, 2024 - 14:45 UTC
Investigating
As of 10:18 UTC, our Engineering team is investigating an issue with creating PostgresSQL Managed Database clusters via our Cloud Control Panel.

During this time, users may face issues creating the PostgreSQL Databases from the Cloud Control Panel. The creation of clusters below v16 remains unaffected at the moment.

We apologize for the inconvenience and will share an update once we have more information
Posted Feb 27, 2024 - 10:40 UTC
This incident affected: Managed Databases (AMS3, BLR1, FRA1, LON1, NYC1, NYC2, NYC3, SFO2, SFO3, SGP1, SYD1, TOR1).