As of 05:55, our Engineering team has resolved the issue impacting Python builds for the App platform. The users will not be experiencing the error "Requested runtime 'python-3.11.3' is not available for this stack (heroku-18)" during the build deployment.
We appreciate your patience throughout the process and if you continue to experience problems, please open a ticket with our Support team for further review.
Posted Aug 16, 2023 - 06:05 UTC
Monitoring
As of 05:18 UTC, our Engineering team has deployed a fix to resolve the issue impacting Python builds for App platform. We are actively monitoring the situation to ensure stability and will provide an update once the incident has been fully resolved. Thank you for your patience and we apologize for the inconvenience.
Posted Aug 16, 2023 - 05:28 UTC
Update
Our Engineering team continues work on the rollout with the fix for Python builds failing in App Platform.
We've identified that a very small number of Apps are impacted by this issue - less than 1% of users have encountered this issue.
We will post an update once the rollout completes.
Posted Aug 16, 2023 - 01:30 UTC
Identified
Our Engineering team has investigated and identified an issue impacting Python builds for App Platform. Beginning approximately 17:30 UTC, users will see the error "Requested runtime 'python-3.11.3' is not available for this stack (heroku-18)".
The team is in the process of rolling out a fix.
In the meantime as a workaround, users may update their Apps to use the Ubuntu 22.04-based stack. This stack is in beta, but provides dependency upgrades, and removes support for PHP version 8.0 and earlier. To update, users will need to specify the new stack in the app spec by adding: "features: - buildpack-stack=ubuntu-22"
We will post another update once the fix has completed rolling out.