Unable to add Node Pools to Managed Kubernetes Clusters via Cloud Control Panel
Incident Report for DigitalOcean
Resolved
Our Engineering team has resolved the issue with adding node pools via the Cloud Control Panel. All services should now be operating normally. If you continue to experience problems, please open a ticket with our support team. We apologize for any inconvenience.
Posted May 14, 2020 - 17:00 UTC
Monitoring
Our Engineering team has deployed the fix to resolve the issue with adding node pools to Managed Kubernetes Clusters and is monitoring the situation. We will post an update as soon as the issue is fully resolved.
Posted May 14, 2020 - 16:36 UTC
Identified
Our Engineering team has identified the cause of the issue with adding node pools to Managed Kubernetes Clusters in our Cloud Control Panel and is actively working on a fix. We will post an update as soon as the fix is in place.
Posted May 14, 2020 - 15:54 UTC
Investigating
Our Engineering team is investigating an issue with adding node pools to existing Managed Kubernetes Clusters via our Cloud Control Panel. During this time, users may be unable to utilize the button in the control panel to add node pools to their clusters. Users should be able to add node pools via API correctly, and creation of new Managed Kubernetes Clusters is still functioning correctly at this time. We apologize for the inconvenience and will share an update once we have more information.
Posted May 14, 2020 - 15:25 UTC
This incident affected: Regions (Global) and Services (Kubernetes).