The scheduled maintenance for our core networking infrastructure in the NYC3 region, originally planned for March 5, 2025, from 23:00 UTC to March 6, 2025, 01:00 UTC, has been cancelled. No changes will be made at this time, and all services will continue to operate as usual.
We will provide an update when this maintenance has a new confirmed date. If you have any questions, please reach out to our support team via Cloud Support.
Thank you for your understanding.
Posted Mar 05, 2025 - 23:52 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 05, 2025 - 23:00 UTC
Scheduled
Start: 2025-03-05 23:00 UTC End: 2025-03-06 01:00 UTC
During the above window, our Networking team will be making changes to core networking infrastructure, to improve performance and scalability in the NYC3 region.
Expected impact:
During the maintenance window, users may experience brief delays or failures in event processing for up to 5 minutes. This may affect Droplets and Droplet-based services, including Managed Kubernetes, Load Balancers, Container Registry, and App Platform. Additionally, regular requests via the Public API, as well as viewing and submitting requests through the Cloud Control Panel, may time out or fail for up to 5 minutes.We will endeavor to keep this to a minimum for the duration of the change.