Issues with Managed Databases settings
Incident Report for DigitalOcean
Resolved
Our Engineering team has resolved the issue with Managed Databases and should now be operating normally. If you continue to experience problems, please open a ticket with our support team. We apologize for any inconvenience.
Posted Jul 10, 2020 - 12:00 UTC
Monitoring
Our Engineering team has implemented a fix to resolve the issue with Managed Databases. We'll continue monitoring the situation, and post an update as soon as the issue is fully resolved.
Posted Jul 10, 2020 - 11:33 UTC
Update
Our Engineering team is continuing to work on a fix for the issue with Managed Databases. At this time, we've also identified that Managed Database creations and deletions are impacted, along with adding read-only nodes. Connections to Managed Databases continue to function correctly. Thank you for your patience.
Posted Jul 10, 2020 - 06:43 UTC
Identified
Our Engineering team has investigated and identified an issue with settings for Managed Database Clusters in all regions. At this time, users may experience latency and/or errors when working with Managed Database settings, such as adding users, adding trusted sources, updating maintenance windows, and other settings actions for Managed Databases.

Connectivity is not impacted, and all connections should still be successful. We are actively working on a fix and will post an update as soon as additional information is available.
Posted Jul 10, 2020 - 06:26 UTC
This incident affected: Regions (Global) and Services (Managed Databases).