Our Engineering team has confirmed the full resolution of the issue with the Billing page for Teams on the Cloud Control Panel. Services should now be operating normally.
Thank you for your patience, and we apologize for any inconvenience. If you continue to experience any issues, please open a Support ticket right away.
Posted Mar 25, 2025 - 07:30 UTC
Monitoring
Our Engineering team has now mitigated the issue that affected the Billing page for Teams on the Cloud Control Panel and is currently been monitored. Users should no longer see errors when attempting to access or perform actions within the Cloud Control Panel.
We will continue to monitor this at our end and will share an update once the problem is resolved completely.
Posted Mar 25, 2025 - 07:01 UTC
Identified
Our Engineering team has Identified the cause of the issue with Billing page on the Control Panel and is actively working on a fix. We will post an update as soon as the issue is fully resolved.
Posted Mar 25, 2025 - 06:32 UTC
Investigating
Our Engineering team is investigating an issue with the Billing page for Teams on the Cloud Control Panel. During this time, users may receive error messages when attempting to access or perform actions within the Cloud Control Panel. We apologize for the inconvenience and will share an update once we have more information.
Posted Mar 25, 2025 - 06:06 UTC
This incident affected: Event Processing (Global) and Billing, Cloud Control Panel.