Our Engineering team has resolved the issue with the email delivery delays. Services should now be operating normally.
If you continue to experience problems, please open a ticket with our support team. We apologize for any inconvenience.
Posted Apr 24, 2025 - 04:41 UTC
Monitoring
Our Engineering team has confirmed the email delivery delays caused by an issue with an upstream provider has been mitigated. We are now seeing successful delivery of previously delayed emails, as well as normal flow of new messages.
We are currently monitoring the situation closely and will share an update as soon as the issue is fully resolved.
Posted Apr 24, 2025 - 00:28 UTC
Identified
Our Engineering team is aware of an issue with an upstream provider that is impacting the delivery of emails from DigitalOcean to DigitalOcean customers.
Beginning 20:55 UTC, users may experience delays in receiving emails from DigitalOcean, including sign-in verification codes, sign-up verifications, maintenance notifications, and other transactional emails.
Our team is closely monitoring the situation and has begun to see signs of recovery, with both delayed and recent emails starting to be delivered.
We will provide further updates as they are available.