The scheduled maintenance for our core networking infrastructure in the LON1 region, originally planned for March 18, 2025, from 20:00 UTC to 23:00 UTC, has been cancelled. No further changes will be made at this time, and all services are currently operating as expected.
During the scheduled window, we encountered an issue that caused a brief impact on services. As a result, we decided to roll back the maintenance to prevent further disruption. We appreciate your patience and understanding during this time.
We will provide an update once a new date for the maintenance has been confirmed. If you have any questions or experience any ongoing issues, please reach out to our support team via Cloud Support.
Thank you for your understanding.
Posted Mar 18, 2025 - 22:44 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 18, 2025 - 20:00 UTC
Scheduled
Start: 2025-03-18 20:00 UTC End: 2025-03-18 23:00 UTC
During the above window, our Networking team will be making changes to the core networking infrastructure to improve performance and scalability in the LON1 region.
Expected impact:
During the maintenance window, users may experience delays or failures with event processing for a brief duration on Droplets and Droplet-based services, including Droplets, Managed Kubernetes, Load Balancers, Container Registry, and App Platform. We will endeavor to keep this to a minimum for the duration of the change.