Timeout Errors on Viewing Spaces in Control Panel
Incident Report for DigitalOcean
Resolved
Our engineering team has resolved the issue causing some users to experience delays or timeout errors loading Spaces in the Cloud Control Panel; however, a small number of users may not be able to view stats on the Spaces tab, but stats should be available when viewing the content of that Space. We apologize for the inconvenience caused by this issue, and ask that you open a ticket with our support team if you continue to experience problems.
Posted 8 months ago. Apr 13, 2018 - 15:11 UTC
Update
Our engineering team is currently monitoring the issue causing some users to experience delays or timeout errors loading Spaces in the Cloud Control Panel. Some UI functionality, including the object count in each Space and the size of the Space in total, may intermittently fail to load while we continue to mitigate the issue. Please note S3 API functionality has not been affected. Our recent efforts should improve performance for users while we work towards a full resolution. We appreciate your patience and apologize for any inconvenience this has caused.
Posted 8 months ago. Apr 13, 2018 - 12:21 UTC
Monitoring
Our engineering team continues to monitor the issue causing some users to experience delays or timeout errors loading Spaces in the Cloud Control Panel. Some UI functionality, including the object count in each Space and the size of the Space in total, may intermittently fail to load while we continue to mitigate the issue. Our recent efforts should improve performance for users while we work towards a full resolution. Please note: S3 API functionality is not impacted. We apologize for any inconvenience and we will look to post an update before 12:00 UTC on 2018-04-13 or sooner if we have a material change. We appreciate your patience.
Posted 8 months ago. Apr 13, 2018 - 00:30 UTC
Investigating
While our engineering team continues to investigate the issue causing delays or timeout errors loading Spaces in the Cloud Control Panel for some users, some UI functionality, including the object count in each Space and the size of the Space in total, remains disabled. Please note: S3 API functionality is not impacted. The current mitigation efforts should improve performance for users while we work to resolve this issue. We apologize for any inconvenience and will continue to post updates as more information becomes available.
Posted 8 months ago. Apr 12, 2018 - 23:20 UTC
Update
Our engineering team is continuing to investigate the issue causing delays or timeout errors loading Spaces in the Cloud Control Panel for some users. In order to improve performance for users while we work to identify the root cause and fully resolve the issue, we will disable some UI functionality, including the object count in each Space and the size of the Space in total. We apologize for any inconvenience and will continue to post updates as more information becomes available.
Posted 8 months ago. Apr 12, 2018 - 19:04 UTC
Update
Our engineering team is continuing to investigate the issue causing delays or timeout errors loading Spaces in the Cloud Control Panel for some users. The issue has been narrowed down to slowness at a subset of endpoints in the NYC3 region; if users have Spaces in NYC3 and other regions, they may be impacted. We will provide updates as we work to confirm the root cause and to resolve the issue.
Posted 8 months ago. Apr 12, 2018 - 16:24 UTC
Update
Our engineering team is continuing to work on the issue causing delays or timeout errors for users loading Spaces in the Cloud Control Panel. We will share an additional update as we have new information.
Posted 8 months ago. Apr 12, 2018 - 13:21 UTC
Identified
Our engineering team has identified the cause of the issue with Spaces in Control Panel and is actively working on a fix. We will post an update as soon as additional information is available.
Posted 8 months ago. Apr 12, 2018 - 11:31 UTC
Update
Our engineering team continues to investigate the issue related to viewing Spaces in the control panel in our NYC3 region. We appreciate your patience and will post an update as soon as additional information is available.
Posted 8 months ago. Apr 12, 2018 - 10:29 UTC
Investigating
Our engineering team is investigating an issue related to viewing Spaces in the control panel that some users may experience. We apologize for the inconvenience and will share an update once we have more information.
Posted 8 months ago. Apr 12, 2018 - 08:43 UTC
This incident affected: Regions (NYC3) and Services (Spaces).