Our engineering team has resolved the issue with the Billing page for Team accounts in the Cloud Control Panel.
Thank you for your patience. If you continue to experience any problems, please open a support ticket from within your account.
Posted Jul 13, 2023 - 02:33 UTC
Monitoring
As of 01:20 UTC, Our Engineering team has implemented a fix regarding the issue with the Billing page for Team accounts in the Cloud Control Panel. We are monitoring the situation to ensure there is no recurrence.
We will post another update once we confirm the issue is fully resolved.
Posted Jul 13, 2023 - 01:33 UTC
Investigating
As of 01:05 UTC, Our Engineering team is investigating an issue with the Billing page for Teams on the Cloud Control Panel. During this time, users on Team accounts may experience errors while accessing the Billing page.
We apologize for the inconvenience and will share an update once we have more information.
Posted Jul 13, 2023 - 01:27 UTC
This incident affected: Billing and Cloud Control Panel.