DigitalOcean Services Status

App Platform Deployments & Spaces
Incident Report for DigitalOcean
Resolved
From 14:15 to 17:53 UTC, users may have experienced delays for App Platform deployments, as well as latency and errors when fetching Spaces endpoint information and toggling the CDN for a Spaces Bucket, due to an upstream provider issue.

Our Engineering team has confirmed the full resolution of the issue with the upstream provider. Users should now be able to deploy to App Platform and manage their Spaces Buckets as normal.

If you continue to experience problems, please open a ticket with our support team. We apologize for any inconvenience.
Posted Sep 18, 2024 - 20:27 UTC
Monitoring
Our Engineering team continues to monitor the ongoing issue with the upstream provider impacting DigitalOcean Spaces and App Platform services.

Improvements are being seen with lower error rates and latency for App Platform deployments as well as for fetching Spaces endpoints and toggling the CDN for a Spaces Bucket.

We apologize for the inconvenience and will share further updates in the due course.
Posted Sep 18, 2024 - 18:02 UTC
Update
Our Engineering team has identified that the ongoing issue with the upstream provider is also impacting DigitalOcean Spaces. During this time users may experience errors or delays when attempting to fetch the endpoints for a Spaces Buckets, or when enabling/disabling the CDN for a particular bucket.

We apologize for the inconvenience and will share an update when we have additional information.
Posted Sep 18, 2024 - 15:30 UTC
Investigating
Our Engineering team is aware of an upstream provider issue that is causing impact to some DigitalOcean services. More details are being gathered.

At this time, users may experience delayed App Platform deployments.

We apologize for the inconvenience and will provide another update as soon as possible.
Posted Sep 18, 2024 - 15:02 UTC
This incident affected: Spaces (AMS3, FRA1, NYC3, SFO2, SFO3, SGP1, SYD1, BLR1) and App Platform (Global).