From 6:00 UTC to 17:45 UTC, users have experienced issues with Droplet creation and Droplet-based services in the NYC3 region.
Our Engineering team has fully resolved the issue impacting Droplet creation in the NYC3 region. Users can now create Droplets and Droplet-based services, including Managed Kubernetes, Managed Databases, Load Balancers, and snapshots, without any issues.
If you continue to experience problems, please open a ticket with our support team. We apologize for any inconvenience.
Posted Feb 25, 2025 - 20:16 UTC
Monitoring
Our Engineering team has implemented a fix to resolve the issue impacting the creation of Droplets in the NYC3 region. Users should now be able to create Droplets and Droplet-based services including Managed Kubernetes, Managed Databases, Load Balancers, and snapshots without any issues.
We are actively monitoring the situation and will post an update as soon as the issue is fully resolved.
Posted Feb 25, 2025 - 18:43 UTC
Identified
Our Engineering team has identified the reason behind the failed and delayed Droplet creates in the NYC3 region and implemented a partial mitigation to address this issue. As of now, customers may be able to create Droplets and Droplet-based services including Managed Kubernetes, Managed Databases, Load Balancers, and snapshots, however, there might be still some delay in the creates.
We apologize for the inconvenience and appreciate your patience as we work to resolve this issue. Further updates will be shared as they become available.
Posted Feb 25, 2025 - 16:02 UTC
Investigating
Our Engineering team is investigating an issue with Droplet creation in the NYC3 region. During this time, users may see an elevated failure rate for the creation of Droplets and other Droplet-based products, such as Load Balancers, Managed Databases, or Kubernetes in the NYC3 region.
We apologize for the inconvenience and will share an update once we have more information.
Posted Feb 25, 2025 - 12:45 UTC
This incident affected: Kubernetes (NYC3), Managed Databases (NYC3), Droplets (NYC3), Event Processing (NYC3), and Load Balancers (NYC3).