As of 17:05 UTC, our Engineering team has resolved the issue affecting new account sign-ups. Users should no longer experience errors and are now able to complete the sign-up process successfully.
If you continue to experience problems, please open a ticket with our support team. We apologize for any inconvenience.
Posted Sep 27, 2024 - 18:16 UTC
Monitoring
Our Engineering team has implemented a fix to resolve the issue affecting new account sign-ups. Users should no longer encounter errors and can now successfully sign up again.
Our Engineering team is continuing to monitor the situation, and we will provide an update as soon as the issue is fully resolved.
Posted Sep 27, 2024 - 17:23 UTC
Investigating
Our Engineering team is currently investigating an issue affecting registering for a new account at cloud.digitalocean.com. Since 00:00 UTC, some users may encounter errors and be unable to complete the registration process.
We apologize for any inconvenience this may cause and will provide an update as soon as we have more information.