DigitalOcean Services Status

Degradation in Managed Databases

Incident Report for DigitalOcean

Resolved

From As of 16:34 to 19:47 UTC, may have encountered errors listing backup operations for their PostgreSQL, MySQL, OpenSearch, Redis and Kafa clusters through the API and UI. Our Engineering team has confirmed full resolution of the issue, users should no longer experience issues with listing backup operations.

Thank you for your patience, and we apologize for the inconvenience. If you continue to experience problems, please open a ticket with our support team from within your Cloud Control Panel.
Posted Dec 04, 2025 - 22:04 UTC

Monitoring

As of 19:47 UTC, our Engineering team has implemented a fix for the errors on Managed Database list backup operations, which was related to a dependency issue. The situation is currently improving, and we are seeing a reduction in error rates.

The impact was limited to list backup operations for PostgreSQL, MySQL, OpenSearch, Redis, and Kafka engines, where users may have experienced errors when attempting to retrieve a list of backups through both the API and UI. We are now monitoring the situation to ensure that the fix is fully effective and that all operations are functioning normally.

Users should no longer experience errors when listing backups, and all other control plane operations, such as creating, updating, or deleting databases, should continue to function normally.

We will continue to monitor the situation to ensure that the issue is fully resolved.

We apologize for the disruption and appreciate your patience.
Posted Dec 04, 2025 - 21:22 UTC

Investigating

As of 16:34 UTC, our Engineering team is investigating reports of errors and timeouts on control plane operations for Managed Databases. The issue is affecting multiple database engines, including PostgreSQL, MySQL, OpenSearch, Redis, and Kafka.

Users may experience errors or timeouts when attempting to list backups, through both the API and UI. We want to emphasize that this issue does not currently appear to be impacting the data plane, and databases should continue to be accessible and functional.

Our team is working to determine the root cause of the issue and will share an update once we have more information. We apologize for the inconvenience and appreciate your patience as we work to resolve this incident.

We will provide further updates as soon as more information is available.
Posted Dec 04, 2025 - 18:03 UTC
This incident affected: Managed Databases (Global).