DigitalOcean Services Status

Networking in LON1

Incident Report for DigitalOcean

Resolved

This incident has been resolved.
Posted Apr 28, 2025 - 11:17 UTC

Investigating

Between 09:58 UTC and 10:11 UTC, our Engineering team observed issues impacting DNS resolution in our LON1 region. During this time, some users may have experienced errors while trying to resolve domain names from within Digitalocean resources.

Our team was able to take quick action to mitigate the impact and resolve the issue, and all services in the LON1 region are now functioning normally. Thank you for your patience, and we apologize for any inconvenience.

If you are still experiencing issues or have additional questions, please open a Support ticket right away.
Posted Apr 28, 2025 - 11:14 UTC
This incident affected: Networking (LON1).