DigitalOcean Services Status

DNS Services and App Platform Deployments
Incident Report for DigitalOcean
Resolved
Our Engineering team has confirmed full resolution of this incident.

From 12:24 - 13:26 UTC, we experienced an issue that impacted our DNS API services. During this time, customer deployments to App Platform will have failed to process, and managing domains and DNS records through both the Cloud Control Panel and API would have been unavailable.

If you continue to experience problems with either of these services please open a ticket with our support team from within your Cloud Control Panel. Thank you for your patience.
Posted May 20, 2023 - 14:55 UTC
Monitoring
Our Engineering team identified that the root cause of the issues impacting App Platform deployments was a wider issue involving our DNS API. Along with the App Platform deployment errors, customers would have experienced trouble viewing and editing domains and their DNS records through both the Cloud Control Panel and the API.

A fix has been rolled out and as of 13:26 UTC customers should no longer be experiencing any issues involving the services listed above. Our team will continue to monitor the situation to ensure stability and provide a final update as soon as we confirm the issue has been fully resolved.

Thank you for your patience.
Posted May 20, 2023 - 13:57 UTC
Investigating
As of 12:24 UTC, Our Engineering team is investigating a global issue with our App Platform service. During this time, users may experience issues while performing any operations for new, updated and deleting deployments.

At this time, previously deployed running Apps are not impacted. We will provide an update as soon as possible.
Posted May 20, 2023 - 12:46 UTC
This incident affected: App Platform (Global).