DigitalOcean Services Status

Creation of Load Balancers and Mongo Managed Databases
Incident Report for DigitalOcean
Resolved
Our Engineering team has completed remediation of the previously stalled Mongo clusters and those clusters are now online.

This incident is now fully resolved. If you have any questions or continue to experience issues, please reach out to Support from within your account.

Thank you for your patience throughout this incident.
Posted Jul 10, 2024 - 20:26 UTC
Update
From 16:24 - 18:44 UTC, Load Balancers and Mongo Managed Databases failed to create successfully. Users experienced success messages, but the create processes did not complete as expected.

As of 18:44 UTC, users are able to create Load Balancers and Mongo clusters normally.

As of 19:00 UTC, all stalled Load Balancer creation operations were completed.

Our Engineering team is working to remediate a small number of stalled Mongo cluster creation attempts from the incident impact period. Users may await these remediation efforts, or simply create a new cluster, which will be successful.

We will post a final update once all stalled clusters have been remediated.
Posted Jul 10, 2024 - 19:50 UTC
Monitoring
The potential fix has completed deployment and has been confirmed to address the root cause of this incident. Users should now be able to create Load Balancers and Mongo Managed Database. Our Engineering team is monitoring the situation and we will post an update as soon as we confirm the issue is fully resolved.
Posted Jul 10, 2024 - 19:02 UTC
Identified
After further investigation, our Engineering team has confirmed that only Mongo Managed Database creates are impacted, along with Load Balancers. Managed Kubernetes is not impacted by this incident.
A potential fix is currently in progress. We will provide another update as soon as possible.
Posted Jul 10, 2024 - 18:14 UTC
Investigating
Our Engineering team is investigating an issue with creation of Load Balancers, Managed Databases, and Managed Kubernetes clusters in all regions, via both the Cloud Control Panel and API. During this time, users may see success messages when initially creating resources, but those requests will not complete. We apologize for the inconvenience and will share an update once we have more information.
Posted Jul 10, 2024 - 18:02 UTC
This incident affected: Kubernetes (AMS3, BLR1, FRA1, LON1, NYC1, NYC3, SFO2, SFO3, SGP1, SYD1, TOR1), Managed Databases (AMS3, BLR1, FRA1, LON1, NYC1, NYC2, NYC3, SFO2, SFO3, SGP1, SYD1, TOR1), and Load Balancers (AMS2, AMS3, BLR1, FRA1, LON1, NYC1, NYC2, NYC3, SFO1, SFO2, SFO3, SGP1, SYD1, TOR1).