DigitalOcean Services Status

Container Registry in SFO3
Incident Report for DigitalOcean
Resolved
Our Engineering team has identified the root cause of the incident to be multiple DB calls causing DB contention. During this time, users might have experienced issues interacting and authenticating with the DigitalOcean Container Registry, creating new container registries, and pushing/deleting images to/from registries.

As of 00:10 UTC, we have confirmed the full resolution of the issue affecting the DigitalOcean Container Registry in the SFO3 region. We appreciate your patience throughout the process and if you continue to experience problems, please open a ticket with our support team for further review.
Posted May 25, 2023 - 02:49 UTC
Update
Our Engineering team continues to investigate the root cause of this incident but has observed a reduction in the error rate with DigitalOcean Container Registry in the SFO3 region.

At this time, users should no longer experience errors while interacting and authenticating with the DigitalOcean Container Registry, creating new container registries, and pushing/deleting images to/from registries.

We will post an update as soon as we have further information. Thank you for your patience.
Posted May 24, 2023 - 22:53 UTC
Investigating
Following an uptick in customer reports of issues with DigitalOcean Container Registries in SFO3, our Engineering team is investigating any potential issues that are causing these reports.

At this time, users may see 500 type errors when uploading/pushing/deleting images, slow cleanup operations, creation failures for new registries, or other errors when interacting with registries in SFO3.

We will post an update as soon as we have further information. Thank you for your patience.
Posted May 24, 2023 - 19:28 UTC
This incident affected: Container Registry (SFO3).