DigitalOcean Services Status

Droplet Event Processing in Multiple Regions
Incident Report for DigitalOcean
Resolved
From 1:23 UTC to 3:04 UTC, users may have experienced issues with events being stuck or delayed, such as powering on/off, and resizing Droplets in the NYC3, AMS2, BLR1, SGP1, and SYD1 regions. Additionally, Managed Database creates were delayed in all regions.

Our Engineering team has confirmed full resolution of the issue, delayed events and new events should complete as normal now.

Thank you for your patience through this issue. If you continue to experience any issues, please open a support ticket from within your account.
Posted Dec 19, 2024 - 05:03 UTC
Update
Our Engineering team has confirmed that new events are succeeding, and we're finalizing cleaning up any stalled events. We will post an update as soon this issue is fully resolved.
Posted Dec 19, 2024 - 04:28 UTC
Monitoring
Events in NYC3 has been enabled now and users may continue to submit new events. We are starting to see success rates with event processing go up.

We will post another update soon. Thank you for your patience.
Posted Dec 19, 2024 - 03:08 UTC
Update
Our Engineering team continues to work to mitigate the issue with event processing in multiple regions.

To help address the issue, we are temporarily disabling all Droplet-related actions in the NYC3 region for a period of 20 minutes. During this time, users in NYC3 will not be able to submit actions, such as creating, resizing, powering on/off, etc.

We apologize for the inconvenience and appreciate your patience as we work to resolve this issue. Further updates will be shared as they become available.
Posted Dec 19, 2024 - 02:42 UTC
Investigating
Our Engineering team is investigating an issue impacting Droplet event processing in multiple regions.

At this time, users may experience issues with events appearing to be stuck or delayed, such as powering on/off, and resizing Droplets in NYC3, AMS2, BLR1, SGP1, and SYD1 regions. Additionally, Managed Database creates are delayed in all regions.

We apologize for the inconvenience and will share an update once we have more information.
Posted Dec 19, 2024 - 01:45 UTC
This incident affected: Event Processing (Global).