DigitalOcean Services Status

Container Registry Latency in Multiple Regions
Incident Report for DigitalOcean
Resolved
Our Engineering team has confirmed the resolution of the issue impacting the Container Registry in multiple regions.

Everything involving the Container Registry should now be functioning normally.

We appreciate your patience throughout the process and if you continue to experience problems, please open a ticket with our support team for further review.
Posted Feb 21, 2024 - 20:43 UTC
Monitoring
Our Engineering team has identified an internal operation within the Container Registry service which was placing load on the service, leading to latency and errors. The team has paused that operation in order to resolve the issue impacting the Container Registry in multiple regions. Users should not be facing any latency issues while interacting with their Container registries and also while building their Apps.

We are actively monitoring the situation to ensure stability and will provide an update once the incident has been fully resolved.

Thank you for your patience and we apologize for the inconvenience.
Posted Feb 21, 2024 - 18:03 UTC
Investigating
Our Engineering team is investigating an issue with the DigitalOcean Container Registry service. Beginning around 20:00 UTC on February 20, there has been an uptick in 401 errors for image pulls from the Container Registry service.

During this time, a subset of customers may experience latency or see 401 errors while interacting with Container Registries. This issue also impacts App Platform builds and users may encounter delays while building their Apps or experience timeout errors in builds as a result. Users utilizing Container Registry for images for deployment to Managed Kubernetes clusters may also see latency or failures to deploy.

We apologize for the inconvenience and will share an update once we have more information.
Posted Feb 21, 2024 - 15:41 UTC
This incident affected: Container Registry (AMS3, FRA1, NYC3, SFO3, SGP1, SYD1).