Our engineering team has confirmed that the issues affecting the new signups have been fully resolved. We appreciate your patience throughout the process and if you continue to experience problems, please open a ticket with our support team for further review.
Posted Sep 23, 2023 - 13:45 UTC
Monitoring
Our Engineering team has implemented a fix to resolve the issue impacting new account signups and monitoring the situation. We will post an update as soon as the issue is fully resolved.
Posted Sep 23, 2023 - 09:53 UTC
Identified
Our Engineering team has identified the issue impacting new account signups and is actively working on a fix. We will post an update as soon as additional information is available.
Posted Sep 23, 2023 - 09:40 UTC
Investigating
As of 08.45 UTC, our Engineering team is investigating an issue with new customer signups. During this time, some new customers are unable to finish the signup process, as the submit button for the initial questionnaire does not proceed further.
We apologize for the inconvenience and will provide an update as soon as possible.