Our Engineering team continues to investigate an issue impacting our DNS API service. During this time, users may experience issues performing domain and DNS record management operations from the Control Panel and API, including creating, updating, or deleting DNS records. As a result, services that depend on DNS API operations, including Let's Encrypt certificate provisioning, MongoDB cluster creation, App Platform deployments, and DigitalOcean Kubernetes (DOKS) cluster create and delete operations, may also be impacted.
We apologize for the inconvenience and will share more information as it becomes available.
Posted Jun 04, 2026 - 10:59 UTC
Investigating
Our Engineering team is investigating an issue impacting our DNS API service. During this time, users may experience issues performing domain and DNS record management operations from the Control Panel and API, including creating, updating, or deleting DNS records. As a result, services that rely on DNS API operations, such as Let's Encrypt certificate provisioning and MongoDB cluster creation, may also be impacted.
We apologize for the inconvenience and will share an update once we have more information.
Posted Jun 04, 2026 - 10:12 UTC
This incident affects: App Platform (Global), Managed Databases (Global), Kubernetes (Global), and DNS.