DigitalOcean Services Status

Let's Encrypt Outage Affecting Certificate Issuance and Managed Databases Operations

Incident Report for DigitalOcean

Resolved

The upstream outage with Let's Encrypt has been resolved. Customers should now be able to issue Let's Encrypt certificates for Spaces, Load Balancers, and App Platform Custom Domains. Our Engineering team has also confirmed that stuck or delayed actions with Mongo, Advanced PG, and Advanced MySQL databases should complete normally now.

We appreciate your patience. If you continue to experience any issues, please open a support ticket from within your account.
Posted May 08, 2026 - 21:54 UTC

Identified

Our Engineering team is aware of an upstream outage with Let's Encrypt (see https://letsencrypt.status.io/) which impacts the following services:

- Inability to create new Let's Encrypt certificates for Spaces, Load Balancers, and App Platform Custom Domains
- Stuck or delayed creates/forks/restores on Mongo, PG, and MySQL databases.

Please note that operations related to Managed Databases and App Platform Custom Domains will automatically retry and should complete successfully once the upstream outage is resolved.

We'll continue to monitor this situation and provide updates. We apologize for the inconvenience.
Posted May 08, 2026 - 20:46 UTC
This incident affected: App Platform (Global), Managed Databases (Global), Load Balancers (Global), Spaces (Global), and Spaces CDN (Global).