Support Portal Unavailable
Incident Report for DigitalOcean
Resolved
Our engineering team has resolved the issue with the Support Portal. Logins to the Support Portal from within our Cloud Control Panel should be successful, and submitting and viewing tickets should now be operating normally. If you continue to experience problems, please open a ticket with our support team. We apologize for any inconvenience.
Posted Nov 07, 2019 - 00:31 UTC
Monitoring
Our engineering team has implemented a fix to resolve the issue with the Support Portal and is monitoring the situation. We will post an update as soon as the issue is fully resolved.
Posted Nov 07, 2019 - 00:00 UTC
Identified
Our engineering team has identified the cause of the issue with the Support Portal, and a fix is actively being worked on. We will post an update as soon as possible.
Posted Nov 06, 2019 - 20:29 UTC
Investigating
Our engineering team is investigating an issue with the Support Portal. During this time, the Support Portal from within our Cloud Control Panel may be unavailable for users to log in, submit, or view tickets.

In the meantime, we ask that users utilize our contact form here: https://www.digitalocean.com/company/contact/#support

We apologize for the inconvenience and will share an update once we have more information.
Posted Nov 06, 2019 - 19:50 UTC
This incident affected: Regions (Global) and Services (Support Center).