DigitalOcean Services Status

Resizing Droplet Attached Block Storage Volumes
Incident Report for DigitalOcean
Resolved
From 17:04 UTC to 21:43 UTC, users may not have seen the option to resize an attached Block Storage Volume via the Cloud Control Panel, or may have encountered errors when attempting to resize attached Volumes via the API.

Our Engineering team has confirmed the resolution of the issue and Volume resizes should now be functioning normally in all regions.

If you continue to experience problems, please open a ticket with our support team. We apologize for any inconvenience.
Posted Sep 09, 2024 - 22:59 UTC
Monitoring
Our Engineering team have implemented a fix for the issue of resizing Droplet-attached Block Storage Volumes in all regions and are monitoring the situation closely. We will post another update once we're confident that the issue is fully resolved.
Posted Sep 09, 2024 - 21:58 UTC
Investigating
Our Engineering team is investigating an issue with resizing Droplet-attached Block Storage Volumes in all regions. Beginning at 17:04 UTC, users may not see the option to resize the Volume via the Cloud Control Panel, as well as see errors when attempting to resize attached Volumes via the API.

At this time, unattached Volumes are able to be resized correctly.

We will post an update once further information is available.
Posted Sep 09, 2024 - 21:15 UTC
This incident affected: API, Cloud Control Panel and Volumes (Global).