DigitalOcean Services Status

Customer Support Ticket Portal
Incident Report for DigitalOcean
Resolved
Given the absence of outages for the Support Portal, we will now resolve this incident. Our Engineering team will continue to work with our vendor to ensure continued stability of this service. If we observe further outages, we will communicate those to our users via new updates on our status page.

We sincerely apologize and thank you for your patience as we worked through this issue. In case of any questions or concerns, please open a ticket with our Support team.
Posted Nov 25, 2024 - 19:20 UTC
Update
Our Engineering team continues to work with our vendor to find a solution, but we have not observed any further outages of our Support Portal over the last 48 hours. We will provide additional updates as information becomes available. If an outage does occur, users may still contact us via the form here: https://www.digitalocean.com/company/contact/support

Thank you for your patience. We will post an update as soon as more information becomes available.
Posted Nov 25, 2024 - 15:56 UTC
Update
Our Engineering team continues to work with our vendor in order to resolve the issue with users accessing the Support Portal. The issue has been escalated and we are awaiting feedback.

As a reminder, if users need to reach out, they can utilize the form here as a workaround:

https://www.digitalocean.com/company/contact/support

Thank you for your patience. We will post an update as soon as further information becomes available.
Posted Nov 22, 2024 - 03:49 UTC
Investigating
Our Engineering team has observed issues with our Support Portal. During brief, recurring outages, users are unable to access the Support Portal at https://cloudsupport.digitalocean.com/. We are aware of these events and our engineers are working with our vendor to resolve this.

As this issue is intermittent, we expect users will be able to log support tickets normally. However, during any periods of unavailability, as a temporary workaround, users may still contact us via the form here: https://www.digitalocean.com/company/contact/support

Thank you for your patience. We will post an update as soon as further information becomes available.
Posted Nov 21, 2024 - 15:40 UTC
This incident affected: Support Center.