DigitalOcean Services Status

Domain Accessibility: .space Domains

Incident Report for DigitalOcean

Resolved

Our Engineering team has confirmed that the issue affecting .space domains has been resolved, and customers should now be able to access their .space domains successfully.

If you continue to experience any issues, please open a support ticket for assistance.
Posted Sep 24, 2025 - 19:07 UTC

Identified

Our Engineering team has identified issues affecting .space domains. As a result, some customers may be unable to access their websites, and zone files may not appear in dig results. The engineers have confirmed that this is an issue with the registry and have informed upstream providers.

We apologize for the inconvenience and will provide updates as soon as more information is available.
Posted Sep 24, 2025 - 15:10 UTC
This incident affected: DNS.