DigitalOcean Services Status

Spaces Object Storage, DigitalOcean Container Registry & App Platform
Incident Report for DigitalOcean
Resolved
Our Engineering team has confirmed complete resolution of the issue that was impacting Spaces Object Storage, DigitalOcean Container Registry, and App Platform, across all regions.

From 16:52 UTC - 18:41 UTC, users may have experienced increased error rates when accessing Spaces objects, interacting with the DigitalOcean Container Registry and while creating/deploying Apps with App Platform. Functionality is completely restored and all operations are succeeding normally.

If you continue to experience any issues with these services please submit a ticket to our customer support team for assistance. Thank you for your patience.
Posted Nov 18, 2024 - 19:33 UTC
Monitoring
Our Engineering team has completed the mitigation efforts and a fix is now deployed in all regions.

As of 18:41 UTC, error rates have returned to normal and users should no longer experience issues accessing, creating, or performing updates on their existing services with the impacted products.

We are monitoring the situation and will provide an update shortly.
Posted Nov 18, 2024 - 19:07 UTC
Investigating
Our Engineering team is investigating an issue impacting Spaces Object Storage, DigitalOcean Container Registry, and App Platform, across all regions.

Beginning at 16:52 UTC, users may have started experiencing 500 errors when trying to access and perform operations with their Spaces bucket, as well as increased failure rates when pushing to Container Registries and creating/deploying Apps.

Our team has started to apply mitigations to correct the issue, which are rolling out across all regions.

We'll provide another update once that process has completed.
Posted Nov 18, 2024 - 18:32 UTC
This incident affected: App Platform (Global), Container Registry (AMS3, BLR1, FRA1, NYC3, SFO2, SFO3, SGP1, SYD1), and Spaces (AMS3, FRA1, NYC3, SFO2, SFO3, SGP1, SYD1, BLR1).