DigitalOcean Services Status

DNS Resolution in FRA1, AMS3 and LON1 Regions
Incident Report for DigitalOcean
Resolved
Our Engineering team has confirmed the workaround fix is successful and all services should now be operating normally. We will now close this incident and work with the DNS provider separately on the root cause.

We appreciate your patience throughout the process and if you continue to experience problems, please open a ticket with our support team for further review.
Posted Jan 29, 2024 - 18:36 UTC
Monitoring
Our Engineering team has identified the root cause of the issue with DNS resolution. DigitalOcean resolvers in use in FRA1, AMS3, and LON1 are unable to reach an upstream DNS provider, resulting in resolution for a subset of domain names being unavailable from our resolvers. Our Engineering team is reaching out to the provider for assistance.

In the meantime, our Engineering team has been able to implement a workaround fix by filtering some incorrectly announced network routes. At this time, we are seeing recovery and resolution of hostnames returning to normal in the impacted regions. We'll continue to await an update from the DNS provider. We're now monitoring the workaround fix for stability and will post an update once we are confident it is successful.
Posted Jan 29, 2024 - 18:18 UTC
Investigating
Our Engineering team is currently investigating issues with DNS resolution in FRA1, AMS3, and LON1. During this time, customers may experience errors trying to resolve domain names from within DigitalOcean services in those regions, including Droplets and Droplet-based services, as well as App Platform. Additionally, App Platform builds may fail or experience delays.

We apologize for the inconvenience and will share an update once we have more information.
Posted Jan 29, 2024 - 17:27 UTC
This incident affected: App Platform (Amsterdam, Frankfurt, London) and DNS.