DigitalOcean Services Status

Response Degradation Impacting Kimi-K3

Incident Report for DigitalOcean

Update

Our Engineering team is investigating reports of empty or broken responses impacting Kimi-K3.
At this point, users may experience degraded response quality, specifically empty or broken outputs (including repeated characters), when querying the Kimi-K3 service.
We apologize for the inconvenience and will share an update once we have more information.
Posted Jul 29, 2026 - 21:41 UTC

Investigating

We are currently investigating this issue.
Posted Jul 29, 2026 - 17:56 UTC
This incident affects: Agentic Inference Cloud (Model Services).