DigitalOcean Services Status

Let's Encrypt SSL Provisioning

Incident Report for DigitalOcean

Resolved

Our Engineering team, in collaboration with Let's Encrypt, has successfully resolved the issue affecting SSL certificate provisioning for Spaces and Load Balancers. Certificate creation is now fully restored and functioning as expected.

Existing certificates and HTTPS traffic were not impacted during this time. If you continue to experience any issues with certificate provisioning, please open a support ticket for assistance.

We sincerely apologize for any inconvenience this may have caused and appreciate your patience.
Posted Jul 22, 2025 - 18:55 UTC

Monitoring

Our Engineering team, in collaboration with Let's Encrypt, has implemented a fix to address the issue affecting SSL certificate provisioning for Spaces and Load Balancers. Initial reports indicate that certificate creation is now functioning as expected.

However, we are continuing to monitor the situation closely to ensure full stability. Existing certificates and HTTPS traffic remain unaffected.

We will provide an update once the issue is fully resolved.
Posted Jul 22, 2025 - 14:55 UTC

Update

Our Engineering team continues to investigate an issue affecting the creation of Let's Encrypt SSL certificates through the DigitalOcean Cloud Panel for Spaces and Load Balancers. During this time, users may experience failures or delays when provisioning new certificates.

Our team is actively working to resolve the issue and we will provide further updates as soon as we have more information. Thank you for your continued patience.
Posted Jul 22, 2025 - 09:32 UTC

Investigating

Our Engineering team has identified an issue affecting the creation of Let's Encrypt SSL certificates through the DigitalOcean Cloud Panel for Spaces and Load Balancers. During this time, users may experience failures or delays when provisioning new certificates.

Our team is actively working with Let's Encrypt to resolve the issue as quickly as possible. Existing certificates and traffic over HTTPS are not impacted.

We will continue to provide updates as we learn more.
Posted Jul 21, 2025 - 20:02 UTC