DigitalOcean Services Status

Customer Support Ticket Portal
Incident Report for DigitalOcean
Resolved
Our team has confirmed the full resolution for the problem with our support portal at https://cloudsupport.digitalocean.com/s/ where customers were unable to create tickets with 'Billing' ticket type.

We sincerely apologize and thank you for your patience as we worked through this issue.

In case of any questions or concerns, please open a ticket with our Support team.
Posted Jan 31, 2024 - 15:26 UTC
Monitoring
Our Engineering team has identified the cause of the issue and implemented a fix to resolve the problem with the Support Portal. Users should now be able to create the tickets in the Support portal with Billing ticket type.

We are monitoring the situation now and will post an update as soon as the issue is fully resolved.
Posted Jan 31, 2024 - 15:12 UTC
Investigating
Our Engineering team is investigating an issue with customers being unable to create the support tickets to our support portal for Ticket type "Billing" at https://cloudsupport.digitalocean.com.

As a temporary workaround, users may still contact us via the form here: https://www.digitalocean.com/company/contact/support

We apologize for the inconvenience and will post an update as soon as further information is available.
Posted Jan 31, 2024 - 14:26 UTC
This incident affected: Support Center.