Our Engineering team has confirmed that the issue affecting the Droplet limit increase feature within the Cloud Control Panel has been fully resolved. Requests to increase Droplet limits submitted through the Control Panel are now being processed correctly, and Support tickets are being generated as expected.
If you experience any further issues, please contact Support by creating a Support ticket from within your account.
Thank you for your patience while we worked to resolve this issue.
Posted Feb 16, 2026 - 09:24 UTC
Monitoring
The issue affecting the Droplet limit increase feature within the Cloud Control Panel has been identified and a fix has been implemented.
Requests submitted through the Control Panel are now generating Support tickets as expected. Our team is continuing to monitor the system to ensure full functionality and stability.
If you experience any further issues with Droplet limit increase requests, please contact Support directly by creating a Support ticket from within your account.
Posted Feb 16, 2026 - 08:37 UTC
Investigating
Our Engineering team is currently investigating an issue affecting the Droplet limit increase feature within the Cloud Control Panel.
At this time requests to increase Droplet limits submitted through the Control Panel are not being processed. Customer submissions to increase limits are not generating support tickets as expected. We are actively working to identify the root cause and restore normal functionality as quickly as possible.
If you urgently require a Droplet limit increase, please contact Support directly by creating a Support ticket from within your account.