User Registrations
Incident Report for DigitalOcean
Resolved
Our Engineering team has successfully resolved the issue with Registrations on Cloud Control Panel and the service should now be functioning normally. Thanks for your patience, and if you continue to experience problems, please open a ticket with our support team.
Posted Jun 24, 2022 - 14:38 UTC
Monitoring
As of approximately 13:50 UTC, our Engineering team identified an issue with Registrations failing. During this time, users may have experienced issues and received errors with all registrations on Cloud Control Panel. We have applied a fix for this problem and as of 14:15 UTC, the registrations should succeed without issues. We apologize for the inconvenience and will post another update when the incident is fully resolved.
Posted Jun 24, 2022 - 14:24 UTC
This incident affected: Regions (Global) and Services (Cloud Control Panel).