DigitalOcean Services Status

Droplet Resize Events
Incident Report for DigitalOcean
Resolved
As of 19:37 UTC, our Engineering team has confirmed the full resolution of the problem impacting the Droplet resize events in all regions. All the Droplet resize events should now be succeeding normally.

If you continue to experience problems, please open a ticket with our Support team.

Thank you for your patience and we apologize for the inconvenience.
Posted Feb 07, 2024 - 20:54 UTC
Monitoring
Our Engineering team has fully deployed the fix for the issue with Droplet resizes and is now monitoring the situation. Users can now retry Droplet resizes and should see them succeed.

We'll post another update once we confirm the fix resolves this incident.
Posted Feb 07, 2024 - 19:41 UTC
Identified
Our Engineering team has identified the root cause of the issue with failed Droplet resizes and a fix is in the process of being deployed.

Users attempting to resize Droplets where the image for the Droplet has been deleted or retired (e.g. a user created a Droplet from a Snapshot, but later deleted that Snapshot) will see failures. All other resizes are succeeding normally.

We'll post another update once the fix has completed deployment.
Posted Feb 07, 2024 - 15:49 UTC
Investigating
Our Engineering team is investigating an uptick in failed Droplet resizes, beginning Feb 6, 20:57 UTC.

During this time, some users may experience failures when attempting to resize Droplets, in all regions.

We apologize for the inconvenience and will share an update once we have more information.
Posted Feb 07, 2024 - 15:32 UTC
This incident affected: Event Processing (Global).