DigitalOcean Services Status

Control Panel Visibility

Incident Report for DigitalOcean

Resolved

The issue impacting the visibility of Cloud Panel has been confirmed to be resolved. Between approximately 16:08 PM & 17:56 PM UTC, users may have noticed unusual behavior when accessing the console, performing resizing operations, or experiencing issues with the Cloud Panel visibility.

Our team has taken necessary corrective measures to restore the service, and we can confirm that it is now functioning as expected. We sincerely apologize for the inconvenience caused and truly appreciate your understanding throughout this process.

However, if you continue to experience any issues, please do not hesitate to raise a support ticket for further investigation. We’ll be happy to assist you.
Posted Feb 19, 2026 - 18:42 UTC

Monitoring

Our team has implemented a fix to address the issue affecting the visibility of the Cloud Panel. We are actively monitoring the situation to ensure overall stability.

Users should no longer encounter abnormalities when accessing the console, resizing the Droplet, misalignments within the Cloud Panel, etc. We will provide a further update once the issue is fully confirmed to be resolved.
Posted Feb 19, 2026 - 18:05 UTC

Investigating

Our team is currently investigating an issue impacting the visibility of the Control Panel. Users may notice unexpected behavior, such as being prompted for login credentials when accessing the console, being unable to select radio buttons for any plans during resize, columns appearing squished, etc.

We apologize for the inconvenience and will share further updates as soon as more information becomes available.
Posted Feb 19, 2026 - 17:34 UTC
This incident affected: Cloud Control Panel.