Our Engineering team has confirmed full resolution of the issue with creating Droplets in all regions. Users should be able to create Droplets without issue.
We apologize for the inconvenience. If you continue to face any issues, please open a support ticket from within your account.
Posted Apr 10, 2026 - 21:06 UTC
Monitoring
Subject: Droplet Availability in All Regions
Our Engineering team has identifed an issue with Droplet creates in all regions. A root cause has been found, a fix has been put in place and we are currently monitoring the situation to ensure full resolution. Users should be able to create new Droplets at this time.
We will continue to monitor and we will post an update as soon as it is fully resolved. We apologize for the inconvenience.
Posted Apr 10, 2026 - 20:32 UTC
This incident affected: API, Cloud Control Panel, Event Processing (Global), and Droplets (Global).