DigitalOcean Services Status

DOKS in Multiple Regions
Incident Report for DigitalOcean
Resolved
Our Engineering team has confirmed the full resolution of the issue impacting DOKS across all regions.

After the rollout, we are no longer reliant on that affected upstream provider for our DOKS product.

If you continue to experience problems, please open a ticket with our support team. We apologize for any inconvenience.
Posted Nov 15, 2023 - 01:59 UTC
Monitoring
Our Engineering team has completed the rollout to pivot away from the affected upstream provider and we are no longer reliant on that provider for our DOKS product.

At this time, Users should no longer see any issues with nodes going into not ready states, creating new clusters, or scaling up additional nodes.

We're monitoring the fix and will post another update once we confirm this issue is fully resolved.
Posted Nov 15, 2023 - 00:42 UTC
Update
Our Engineering team is currently working to pivot away from the affected upstream provider to mitigate impact from this incident. That fix is rolling out across our fleet and users should start to see conditions on affected clusters improve.

As soon as the fix is rolled out completely, we'll post another update.
Posted Nov 14, 2023 - 23:24 UTC
Update
Our Engineering team has confirmed an issue on our upstream provider's end impacting DOKS across all regions which was initially reported for a few regions.

During this time, Users will not be able to create new clusters, scale up additional nodes or may see nodes in an unready state across all regions.

We will share an update as soon as we have any information from our upstream provider.
Posted Nov 14, 2023 - 22:20 UTC
Identified
Beginning around 20:00 UTC, our Engineering team has confirmed an issue on our upstream provider's end impacting DOKS in our multiple regions.

During this time, Users will not be able to create new clusters, scale up additional nodes or may see nodes in an unready state.

We will share an update as soon as we have any information from our upstream provider.
Posted Nov 14, 2023 - 21:59 UTC
This incident affected: Kubernetes (AMS3, BLR1, FRA1, LON1, NYC1, NYC3, SFO2, SFO3, SGP1, SYD1, TOR1).