DigitalOcean Services Status

Delay in App Platform Deployments

Incident Report for DigitalOcean

Resolved

As of 18:55 UTC, our Engineering team has confirmed that the issue causing delays in App Platform deployments has been fully resolved. The fix implemented earlier has been successful, and we are no longer seeing any delays or errors with deployments.

Users should now be able to deploy their apps successfully and without any issues. We apologize again for the inconvenience caused.

However, if you continue to experience any issues, please don't hesitate to raise a support ticket for further investigation. We'll be happy to assist you.
Posted Feb 12, 2026 - 19:34 UTC

Monitoring

Our Engineering team has implemented a fix to address the issue causing delays in App Platform deployments.

We are actively monitoring the situation to ensure overall stability. Users may already notice improvements while deploying apps.

We appreciate your patience throughout the process and will provide a further update once the issue is fully confirmed to be resolved.
Posted Feb 12, 2026 - 19:17 UTC

Investigating

Our engineers are currently investigating an issue impacting new App Platform deployments.

During this time, some users may experience delay when creating new App Platform apps. Existing apps are not affected and should continue to function normally.

We apologize for any inconvenience, and we'll share more information as it becomes available.
Posted Feb 12, 2026 - 19:06 UTC
This incident affected: App Platform (Global).