DigitalOcean Services Status

Kubernetes Clusters - Authentication Errors
Incident Report for DigitalOcean
Resolved
Our Engineering team has confirmed the full resolution of the issue with authentication failures on Managed Kubernetes Clusters.

From 19:26 - 23:29 UTC, users saw errors accessing and performing actions on Managed Kubernetes Clusters, due to authentication failures. All services are now operating normally.

If you continue to experience problems, please open a ticket with our support team. Thank you for your patience throughout this incident!
Posted Jan 08, 2024 - 00:32 UTC
Monitoring
Our Engineering team has confirmed that the action taken to mitigate the impact of this incident is successful and customers are no longer seeing issues accessing or performing actions on Managed Kubernetes Clusters.

We'll monitor the situation for a short while and will post a final update once we confirm full resolution.
Posted Jan 08, 2024 - 00:01 UTC
Identified
Our Engineering team has taken action to mitigate the impact of this incident and internal tests on impacted clusters are now passing. At this time, users should start to see recovery and be able to access clusters normally.

We are still investigating root cause and ensuring this mitigation will continue to be successful. We'll provide another update as soon as possible.
Posted Jan 07, 2024 - 23:32 UTC
Investigating
Our Engineering team is investigating customer reports of errors when trying to perform actions on Managed Kubernetes Clusters using kubectl. At this time, customers may see errors indicating that the API token is unauthorized or missing credentials. We will provide an update as soon as we have more information.
Posted Jan 07, 2024 - 22:02 UTC
This incident affected: Kubernetes (AMS3, BLR1, FRA1, LON1, NYC1, NYC3, SFO2, SFO3, SGP1, SYD1, TOR1).