Cloud Control Panel
Incident Report for DigitalOcean
Resolved
Our engineering team has resolved the issue with the Cloud Control Panel. Users with a past due balance should now be able to navigate the control panel normally. If you continue to experience problems, please open a ticket with our support team. We apologize for any inconvenience.
Posted Jul 03, 2022 - 01:37 UTC
Monitoring
Our engineering team has implemented a fix to resolve the issue with the Cloud Control Panel and is monitoring the situation. We will post an update as soon as the issue is fully resolved.
Posted Jul 03, 2022 - 01:01 UTC
Investigating
Our engineering team is investigating reports of an issue with the Cloud Control Panel. At this time, users with a past due balance may experience 404 errors when navigating within the Cloud Control Panel.

We apologize for the inconvenience and will post an update once we have more information.
Posted Jul 02, 2022 - 22:23 UTC
This incident affected: Services (Cloud Control Panel).