DigitalOcean Services Status

Droplet Create Failures in SGP1
Incident Report for DigitalOcean
Resolved
Our Engineering team has resolved the issues with Droplet create failures in our SGP1 region, and all systems should now be operating normally. If you continue to experience any problems, then please open a ticket with our support team right away. Thank you for your patience and we apologize for any inconvenience.
Posted Apr 08, 2024 - 13:21 UTC
Monitoring
Our Engineering team has implemented a fix to resolve the issue with Droplet creates and is monitoring the situation. We will post an update as soon as the issue is fully resolved.
Posted Apr 08, 2024 - 12:48 UTC
Investigating
Our Engineering team is investigating an issue with Droplet creation failures in our SGP1 region. During this time, you may experience issues while creating Droplets in the region.

We apologize for the inconvenience and will share an update once we have more information.
Posted Apr 08, 2024 - 12:11 UTC
This incident affected: Droplets (SGP1).