Cloud Control Panel Errors
Incident Report for DigitalOcean
Resolved
At this time connectivity to our Cloud Panel has been fully restored. If you continue to experience any issues please open a support ticket.
Posted 5 months ago. May 24, 2018 - 13:01 UTC
Monitoring
Connectivity to our Cloud Panel has been restored and we will continue to monitor until it is fully resolved.
Posted 5 months ago. May 24, 2018 - 12:10 UTC
Investigating
Our engineering team is investigating an issue with Cloud Panel being slow intermittently. During this time, you may experience some slowness. We apologize for the inconvenience and will share an update once we have more information.
Posted 5 months ago. May 24, 2018 - 11:39 UTC
This incident affected: Regions (Global) and Services (Cloud Control Panel).