Users unable to make card payments or add new cards
Incident Report for DigitalOcean
Resolved
This incident has been resolved.
Posted 3 months ago. Jul 24, 2017 - 16:18 UTC
Monitoring
We have confirmed that all payments are processing as expected and users are able to add cards to their accounts. If you had trouble making a payment or adding a card in the past few hours, please try again. If you should experience any further issues, please reach out to our support team for assistance.
Posted 3 months ago. Jul 24, 2017 - 15:44 UTC
Update
We have widened the scope of the issue to include all payments being made with credit or debit cards. These payments are currently failing to process and we are working to resolve the problem.
Posted 3 months ago. Jul 24, 2017 - 15:09 UTC
Identified
We have identified the cause of the issue and are currently working to resolve it. We appreciate your patience and understanding in the meantime.
Posted 3 months ago. Jul 24, 2017 - 14:23 UTC
Investigating
We're aware of an issue affecting current and newly created accounts where users are receiving an error message when attempting to add any payment card to their account. We are investigating and hope to have this resolved shortly, thank you for your patience.
Posted 3 months ago. Jul 24, 2017 - 13:35 UTC
This incident affected: Services (Cloud Control Panel).