Abuse Mailbox Delivery Issues
Incident Report for DigitalOcean
Resolved
Our engineering team has resolved the issue with receiving messages to the Abuse mailbox. If you continue to experience problems, please submit your abuse report through the Abuse form (https://www.digitalocean.com/company/contact/#abuse) and open a ticket with our support team. We apologize for any inconvenience this may have caused.
Posted about 1 month ago. Nov 11, 2018 - 19:15 UTC
Monitoring
Our engineering team has implemented a fix to resolve the issue with receiving messages to the Abuse mailbox and is monitoring the situation. We will post another update as soon as the issue is fully resolved.
Posted about 1 month ago. Nov 11, 2018 - 18:31 UTC
Investigating
We are investigating reports of issues receiving messages to the Abuse mailbox. During this time, you may receive an auto-reply, indicating that the inbox is full or cannot accept emails at this time. If you need to submit an Abuse Report, please do so from the contact form at https://www.digitalocean.com/company/contact/#abuse. We apologize for the inconvenience and will post an update here as soon as we have more information.
Posted about 1 month ago. Nov 11, 2018 - 15:40 UTC