DigitalOcean Services Status

All Systems Operational
API Operational
Billing Operational
Cloud Control Panel Operational
Cloud Firewall Operational
Community Operational
DNS Operational
Support Center Operational
Reserved IP Operational
WWW Operational
App Platform Operational
Global Operational
Amsterdam Operational
Bangalore Operational
Frankfurt Operational
London Operational
New York Operational
San Francisco Operational
Singapore Operational
Sydney Operational
Toronto Operational
Container Registry Operational
AMS3 Operational
FRA1 Operational
NYC3 Operational
SFO3 Operational
SGP1 Operational
SYD1 Operational
Droplets Operational
AMS2 Operational
AMS3 Operational
BLR1 Operational
FRA1 Operational
LON1 Operational
NYC1 Operational
NYC2 Operational
NYC3 Operational
SFO1 Operational
SFO2 Operational
SFO3 Operational
SGP1 Operational
SYD1 Operational
TOR1 Operational
Event Processing Operational
Global Operational
AMS2 Operational
AMS3 Operational
BLR1 Operational
FRA1 Operational
LON1 Operational
NYC1 Operational
NYC2 Operational
NYC3 Operational
SFO1 Operational
SFO2 Operational
SFO3 Operational
SGP1 Operational
SYD1 Operational
TOR1 Operational
Functions Operational
AMS3 Operational
BLR1 Operational
FRA1 Operational
LON1 Operational
NYC1 Operational
SFO3 Operational
SGP1 Operational
SYD1 Operational
TOR1 Operational
Managed Databases Operational
AMS3 Operational
BLR1 Operational
FRA1 Operational
LON1 Operational
NYC1 Operational
NYC2 Operational
NYC3 Operational
SFO2 Operational
SFO3 Operational
SGP1 Operational
SYD1 Operational
TOR1 Operational
Monitoring Operational
Global Operational
AMS2 Operational
AMS3 Operational
BLR1 Operational
FRA1 Operational
LON1 Operational
NYC1 Operational
NYC2 Operational
NYC3 Operational
SGP1 Operational
SFO1 Operational
SFO2 Operational
SFO3 Operational
SYD1 Operational
TOR1 Operational
Networking Operational
Global Operational
AMS2 Operational
AMS3 Operational
BLR1 Operational
FRA1 Operational
LON1 Operational
NYC1 Operational
NYC2 Operational
NYC3 Operational
SFO1 Operational
SFO2 Operational
SFO3 Operational
SGP1 Operational
SYD1 Operational
TOR1 Operational
Kubernetes Operational
AMS3 Operational
BLR1 Operational
FRA1 Operational
LON1 Operational
NYC1 Operational
NYC3 Operational
SFO2 Operational
SFO3 Operational
SGP1 Operational
SYD1 Operational
TOR1 Operational
Load Balancers Operational
AMS2 Operational
AMS3 Operational
BLR1 Operational
FRA1 Operational
LON1 Operational
NYC1 Operational
NYC2 Operational
NYC3 Operational
SFO1 Operational
SFO2 Operational
SFO3 Operational
SGP1 Operational
SYD1 Operational
TOR1 Operational
Spaces Operational
AMS3 Operational
FRA1 Operational
NYC3 Operational
SFO2 Operational
SFO3 Operational
SGP1 Operational
SYD1 Operational
BLR1 Operational
Spaces CDN Operational
AMS3 Operational
FRA1 Operational
NYC3 Operational
SFO3 Operational
SGP1 Operational
SYD1 Operational
VPC Operational
Global Operational
AMS2 Operational
AMS3 Operational
BLR1 Operational
FRA1 Operational
LON1 Operational
NYC1 Operational
NYC2 Operational
NYC3 Operational
SFO1 Operational
SFO2 Operational
SFO3 Operational
SGP1 Operational
SYD1 Operational
TOR1 Operational
Volumes Operational
AMS2 Operational
AMS3 Operational
BLR1 Operational
FRA1 Operational
LON1 Operational
NYC1 Operational
NYC2 Operational
NYC3 Operational
SFO1 Operational
SFO2 Operational
SFO3 Operational
SGP1 Operational
SYD1 Operational
TOR1 Operational
Operational
Degraded Performance
Partial Outage
Major Outage
Maintenance
Scheduled Maintenance
NYC2 Network Maintenance May 2, 2024 12:00-15:00 UTC
Start: 2024-05-02 12:00 UTC
End: 2024-05-02 15:00 UTC

During the above window, our Networking team will be making changes to core networking infrastructure, to improve performance and scalability in the NYC2 region.

Expected Impact:

These upgrades are designed and tested to be seamless and we do not expect any impact on customer traffic due to this maintenance.

If an unexpected issue arises, affected Droplets and Droplet-based services could experience increased latency or disruption in public network traffic for a short period of time. If an unexpected issue does occur, our team is prepared to rollback to a safe state to quickly restore public networking. We expect that traffic would be impacted for a period of 5-10 minutes, at most, in that case.

If you have any questions related to this issue please send us a ticket from your cloud support page. https://cloudsupport.digitalocean.com/s/createticket

Posted on Apr 30, 2024 - 15:32 UTC
Past Incidents
May 1, 2024

No incidents reported today.

Apr 30, 2024
Resolved - Our Engineering team has confirmed the root cause of this issue. Preparation work for the upcoming maintenance in NYC2 (https://status.digitalocean.com/incidents/z9r8gg95bqqm) was in-flight and had an unexpected impact, causing the connectivity outage. This was corrected and should not occur again.

All services were restored as of 16:06 UTC and we confirmed this incident impacted only a subset of customer Droplets in NYC2.

We apologize for the disruption and appreciate your patience while the root cause was confirmed. If you have any questions or concerns, please reach out to Support from within your account. Thank you.

Apr 30, 16:58 UTC
Monitoring - Our Engineering team has investigated and identified an issue with networking in our NYC2 region. From 15:54 - 16:06 UTC, services in our NYC2 region experienced a complete disruption in network availability. Users attempting to access Droplet and Droplet-dependent resources would have seen connections failing.

Our team has identified a breaking change and a rollback was completed. We are confirming full scope of impact and ensuring this issue will not reoccur.

We'll post another update soon.

Apr 30, 16:23 UTC
Apr 29, 2024

No incidents reported.

Apr 28, 2024

No incidents reported.

Apr 27, 2024

No incidents reported.

Apr 26, 2024
Resolved - Our Engineering team has continued to actively monitor the situation resulting from multiple subsea fiber faults in our Singapore (SGP1) region, and Asian customers attempting to reach DigitalOcean resources hosted in our Amsterdam (AMS2, AMS3), London (LON1), and Frankfurt (FRA1) regions. Over the last five days, network connectivity to the Singapore region and Asian regions located in Amsterdam (AMS2, AMS3), London (LON1), and Frankfurt (FRA1) has not experienced any major packet loss or latency. Crews have been able to complete some cable repairs, leading to stability for the regions mentioned.

Repair of all cables from crews is still pending and may continue for multiple weeks. Given the relative stability of routes, we will now close out this incident and provide any needed updates separately.

If users experience a disruption in service or have any questions, we invite them to submit a support ticket from within their account.

Thank you for your patience and understanding throughout this incident.

Apr 26, 00:36 UTC
Update - Our Engineering team continues to work with upstream providers to resolve network connectivity issues that are occurring in multiple regions. As a result of multiple subsea fiber faults between Europe and Asia regions, the issues appear to be a direct consequence of congestion resulting in packet loss and increased latency connecting to the SGP1 region. Customers in the Asian region are having difficulty reaching DigitalOcean resources located in Amsterdam (AMS2, AMS3), London (LON1), and Frankfurt (FRA1).

We have no ETA for the upstream issues being restored but we will communicate any relevant information as we have it. We apologize for the inconvenience.

Apr 21, 11:56 UTC
Identified - We've confirmed the degraded network performance in our first update is due to a cable cut, which occurred at approximately 18:00 UTC, April 19. This cable is located just west of Singapore and impacts the cabling system connecting 17 countries from Singapore to Europe. Users can read more about the cable here: https://www.submarinenetworks.com/en/systems/asia-europe-africa/smw5


We continue to monitor this situation and progress of the repair. Our Engineering team will also continue to tune for performance and alternate routes where possible, until the issue is resolved.

If you have any questions, please open a Support ticket from within your account.

Apr 20, 16:20 UTC
Investigating - Due to multiple simultaneous subsea fibre cuts between Europe and Asia, we are observing degraded performance for European customers attempting to reach DigitalOcean resources hosted in our Singapore (SGP1) region, and Asian customers attempting to reach DigitalOcean resources hosted in our Amsterdam (AMS2, AMS3), London (LON1), and Frankfurt (FRA1) regions.

Engineers are attempting to improve performance where possible, but as this issue is largely out of our control we do not expect a substantial improvement in performance until one of the fibre cuts is repaired.

We apologize for any inconvenience.

Apr 20, 12:10 UTC
Apr 25, 2024

No incidents reported.

Apr 24, 2024

No incidents reported.

Apr 23, 2024

No incidents reported.

Apr 22, 2024

No incidents reported.

Apr 21, 2024
Apr 20, 2024
Apr 19, 2024

No incidents reported.

Apr 18, 2024

No incidents reported.

Apr 17, 2024

No incidents reported.